Installation fails: "uxcheckport: IO_X_PORT port seems to be in use "
search cancel

Installation fails: "uxcheckport: IO_X_PORT port seems to be in use "

book

Article ID: 85576

calendar_today

Updated On:

Products

CA Automic Dollar Universe

Issue/Introduction

When installing Dollar Universe on a server with multiple network cards, the installation could fail stating that the ports were already used.

The following error appeared on the installation output ( being 10600 the port chosed when installing):

uxcheckport: 10600 port seems to be in use 

Or, in more recent versions on Cluster nodes:

uxcheckport: can not retrieve local IP address

Environment

OS: All

Product: Dollar Universe

Version: 6.x and 7.x

Cause

The uxchckport was not able to retrieve the local ip address of the HP-UX system where several virtual servers with different hostnames / ip addresses that were unique had been set.

Resolution

Fix Status: Released

Fix Version(s):
Component: Application.Server
Version: Dollar.Universe 6.4.21

A new parameters has been added to uxchckport -h, to specify on which host the command should be applied.
This parameter is now filled with the hostname given during the first step of the installation.

Additional Information

If you still experience the error when installing a node on version superior to 6.4.21, please make sure that the netstat -i output (Unix/Linux) contains an entry for the hostname being used when installing the node.

If you are installing a node on a Cluster Server, then please check that this prerequisite was met and that the virtual hostname and its IP adress was properly added in the DNS before installing the node.

Else, you can use the IP of the Virtual Host instead of the hostname to avoid the error while checking the ports.