spectrumgtw probe will not start after Primary Hub machine was rebooted
search cancel

spectrumgtw probe will not start after Primary Hub machine was rebooted

book

Article ID: 8555

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

This issue begin after the Primary UIM server restart due to Windows patches being installed.

 spectrumgtw 8.6hf3 never gets a PID, only a port.

 

 The probe hangs on startup and restarts

 

Sep 24 2017 16:54:25,605 [main] INFO com.nimsoft.pf.common.log.Log - =========== START: ShutdownAndRestartCleanup(true) ========

 

Sep 24 2017 16:54:25,605 [main] INFO SpectrumGtwProbe - spectrumgtw shutdownAndRestartCleanup START with stoppingFlag true

Sep 24 2017 16:54:25,605 [main] TRACE SpectrumGtwJobsScheduler - stopAllScheduledJobs START

Sep 24 2017 16:54:25,605 [main] TRACE SpectrumGtwJobsScheduler - stopAllScheduledJobs END

Sep 24 2017 16:54:25,605 [main] INFO com.nimsoft.pf.common.log.Log - =========== DONE: ShutdownAndRestartCleanup ========

Sep 24 2017 16:54:25,606 [main] DEBUG com.nimsoft.pf.common.log.Log - DefaultDiscoveryPublisherEngineService.stop: Discovery publishing engine is stopping.

Sep 24 2017 16:54:25,606 [blisher(Managed - 0)] DEBUG com.nimsoft.pf.common.log.Log - DiscoveryPublisherEngineThread.run: Exiting Discovery Publisher on interrupt.

Sep 24 16:57:15:972 [main, spectrumgtw] done constructing GenCallbackHandler

 

 

Environment

UIM 8.51 Version: 8.61 hardfix 3 OS: Windows 2012 spectrumgtw 8.6hf3

Cause

Not reproducible in the LAB environment.

Resolution

1. spectrumgtw 8.6hf3 probe is grey as "deactivated" status.

2. Validate the probe and turns to green and assign PORT and PID then PID drops immediately then RED.

3. Try to deactivate the probe however it will take long time, validate the probe then turns to green and assign both PORT and PID then PID drop.

4. Force to deactivate the probe in Controller Probe Utility in probe deactivate and stop then is able to deactivate the probe however it still show as RED.

5. Create backup folder of cache folder in prob,relocate the contents and restart the probe and port and pid is assigned.

6. Check from the Spectrum side, it will be working.

 

 

 

 

Additional Information

NOTE: Without multiple reboots, the issue does not reoccur.