How to handle the stdlog error messages: "i18nMsg.c Can't Construct Translator" / "i18nMsg.c Unable to open language library"?
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How to handle the stdlog error messages: "i18nMsg.c Can't Construct Translator" / "i18nMsg.c Unable to open language library"?

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Article ID: 8552

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Customer gets the Secondary Server stdlog file full of the following messages:

10/25 17:38:16.16 <server-name> domsrvr:21           7196 ERROR        i18nMsg.c              382 Can't Construct Translator

10/25 17:38:22.52 <server-name> domsrvr:21           7196 ERROR        i18nMsg.c              490 Unable to open language library

 

Environment

Service Desk Manager 12.9 / 14.1 / 17

Cause

The file $NX_ROOT\bin\pdm.dll may be corrupted or missing in the folder on the Secondary Server

Resolution

Copy the pdm.dll file from a working (Primary or Secondary) Server to the non working Server.

Restart the Service Desk services is NOT REQUIRED

Additional Information

The information in this article has been included in our product documentation. You can find further details here:
https://docops.ca.com/casm171/troubleshooting/troubleshooting-ca-service-desk-manager/i18nmsg-c-can-t-construct-translator-stdlog-error-message