Troubleshooting Automation Engine (Master) in TROUBLE status

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Article ID: 85086

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

Error Message :
N/A

The Explorer window shows the Automation Engine in a Trouble status.

Investigation

The Trouble status is set by the Automation Engine when it decides that the Agent is not doing its task (for example, the Automation Engine sent a task to start 5 minutes ago, but the Agent never started it).  The so_back.so_last_activity has not been updated for the amount set in the Sleep time field + 60 seconds.

References

 
Application Manager 9.1 Documentation
User Guide > Automation Engine/Agent Status Values

 

Cause

Cause type:
Other
Root Cause: The Trouble status is set by the Automation Engine when it decides that the Agent is not processing its tasks.

Environment

OS Version: N/A

Resolution

Check the following to resolve an RmiServer in Trouble status:

  • Make sure the RMI server is running.
  • Automation Engine: Locked row in database. May need to run listpids.sql to find any hung Oracle processes and stop them.
  • Agent: Verify that there is adequate disk space.
  • Look at the automation engine and agent log files in log directory. Check the files for errors and verify that all parameters are set correctly for the agent.
  • Look into system CPU and memory usage for other processes that might be impacting Applications Manager operation.
  • Check View> View Connections> Rmi Servers> If an RmiServer has its Master column set to ok, and it does not have a Session ID, double click the Ok to set it to No. Then double click the No if RmiServer with a session ID has No in its Master column.

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Fix Status: No Fix

Fix Version(s):
N/A

Additional Information

Workaround :
N/A

Attachments

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