Agent Last Check column not populated
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Agent Last Check column not populated

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Article ID: 85077

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Error Message :
N/A

After upgrading the Automation Engine (AE) to version 11, the Last check column in the System Overview is showing no information for the Agents.

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0EMb0000001Qrb3.png


Investigation

Scenario 1: The Srvquery is set to ‘0’ in the configuration file ucsrv.ini.

System Overview:

<Please see attached file for image>

0EMb0000001Uyzr.png

Cross check using a database query:

SELECT OH_NAME AS Agent_Name,
       ACTEX_LastAlive last_check
FROM OH,
     HOST,
     ACTEX
WHERE OH_IDNR =HOST_OH_IDNR
  AND OH_IDNR =ACTEX_OH_IDNR
  AND OH_OTYPE ='HOST'
  AND HOST_ACTIVE = 1
ORDER BY 1;

<Please see attached file for image>

0EMb0000001Uyzw.png

Scenario 2: Srvquery is set to ‘1’ in the configuration file ucsrv.ini.

From the System Overview, pressing the Refresh button shows no visible change:

<Please see attached file for image>

0EMb0000001Uz01.png

Double check using a database query and you will see that the database has not been updated.

<Please see attached file for image>

0EMb0000001Uz06.png
 

Environment

OS Version: N/A

Cause

Cause type:
Configuration
Root Cause: The issue occurs when srvquery is set to 1. It should be set to 0 for the field to be populated.

Resolution

In order to have the Last check column in the System Overview of the Java User Interface (UI) to be updated, the srvquery parameter needs to be set to ‘0’ in the ucsrv.ini file.

It is possible to set this parameter to 1 when the Primary Worker Process (PWP) performance is degraded.
 
Setting srvquery=1 lets the Communication Process (CP) layer respond to the Agent being active. With this, the implementation logic of the PWP (among other things, the updating of the Last check column) is turned off and the response to the Agent(s) is much faster.  This is by design. The CP layer is a transport layer only with no logic in it.  Usually the flag is set to 1 when PWP performance degrades in installations with a substantial number of Agents.
 
Setting this parameter to 1 turns off the implementation logic of the Agent’s signs of life within the PWP.  As a result, the column Last check in the Agent Overview will not be updated.

Both the PWP and CPs respond to the Agent's signs of life messages.

BEWARE: Setting srvquery to 0 can affect system performance in installations with a substantial number of Agents.  Therefore, if performance issues on the PWP are experienced after setting the parameter to 0, change the setting back to 1. 

Reference

Automic Workload Automation 12.0 Documentation:
Administration Guide > Administering the Automation Engine > Configuration > Structure of the INI file


Additional information has been added to the Product Documentation in the fix version listed below.
 

Fix Status: Released

Fix Version(s):
Component(s): Documentation

Automation Engine 12.1.0 - Available

Additional Information

Workaround :
N/A

Attachments

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