File Transfer (JOBF) fails on Windows Agent when *OWN Login Object is lowercased
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File Transfer (JOBF) fails on Windows Agent when *OWN Login Object is lowercased

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Article ID: 85033

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Error Message :
U0063031 FT '1662058': Cannot log on as user '*own\UC4'. Error: '1326 - Logon failure: unknown user name or bad password.'

The Windows Agent doesn't recognize the *OWN notation when used in a JOBF if it is written in lowercase and will display the above error message and the File Transfer will not start. Using *OWN (uppercase) in the Login Object works fine within JOBF on a Windows Agent in the same version.

Investigation

The following example is comparing the behavior of the Windows Agent in Automation Engine (AE) 10.0.7 with that of AE 10.0.6.

Create a file transfer object. Reference the User Guide > Process Assembly Perspective > Defining Objects > File Transfer Objects (JOBF).

Define:

  • A source host (e.g. VWGSUP18_WS10_WX6_01_SYS - should be the same for the cross check)
  • A login object for the source host (e.g. ASP:LOGIN.DEFAULT.2)
  • A source file (C:\tmp\asp1.txt
  • The target host (e.g. WIN_NB000502_SP6_01 - will be changed for the cross check)
  • A login object for the target host (e.g. ASP:LOGIN.DEFAULT.5)
  • A target file (C:\Users\UC4\Downloads\asp1.txt)

Windows Agent with Service Pack 6:

<Please see attached file for image>

0EMb0000001Qc1d.png

<Please see attached file for image>

0EMb0000001Qc1i.png

Results:

2016-03-21 15:15:44 - U0011124 Selection started with filter 'C:\tmp\asp1.txt' ... 2016-03-21 15:15:44 - U0011125   'C:\tmp\asp1.txt'
2016-03-21 15:15:44 - U0011126 Files selected: '1'.
2016-03-21 15:15:44 - U0011133 OK     '25' Bytes, '0' Records for file 'C:\tmp\asp1.txt'->'C:\Users\UC4\Downloads\asp1.txt' transferred. Duration '00:00:00'.
2016-03-21 15:15:44 - U0011408 FT '1663020': FileTransfer completed.

Windows Agent with Service Pack 7:

<Please see attached file for image>

0EMb0000001Qc2C.png

<Please see attached file for image>

0EMb0000001Qc2M.png

Results:

2016-03-21 15:16:05 - U0063031 FT '1662058': Cannot log on as user '*own\UC4'. Error: '1326 - Logon failure: unknown user name or bad password.

Environment

OS Version: N/A

Cause

Cause type:
Defect
Root Cause: Windows Agent doesn't recognize when the Automic *OWN notation is not typed in uppercase. This results in an invalid login and the File Transfer will not start.

Resolution

Update to a fix version listed below or a newer version if available.

Fix Status: Released

Fix Version(s):
Component(s): Agent Windows

Automation Engine 12.1.0 - Available
Automation Engine 12.0.1 – Available
Automation Engine 11.2.3 - Available
Automation Engine 11.1.5 – Available

Additional Information

Workaround :
There are 3 recommended options:
  1. Type the *OWN string LOGIN object using uppercase.
OR
  1. Use the domain name instead of *OWN (OWN is a wild-card for substitution).
OR
  1. If using Automation Engine version 10.0.7, you can use the Service Pack (SP) 6 version of the Windows Agent as it is compatible and in that case it would not be necessary to change the existing login-objects.

Attachments

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1558693377769000085033_sktwi1f5rjvs16m6s.png get_app
1558693375976000085033_sktwi1f5rjvs16m6r.png get_app