CA Automic Workload Automation - Automation Engine
Issue/Introduction
Error Message : N/A
ServiceNow Service Connector (SNSC) form fields are out of order after performing an import.
When you use the SNSC to import Workflows into the Service directory, everything appears to work fine. However, the fields are in a different order in the ServiceNow form including the filed headers.
Investigation
The screenshots below display an example of what may be seen.
Before Importing. NOTE: The area marked in red moved down after the import.
<Please see attached file for image>
After Import.
Note: Work Type is now at the bottom of the form.
<Please see attached file for image>
Environment
OS Version: N/A
Cause
Cause type: Defect Root Cause: The order of input-fields is not correctly synchronized between Automation Engine and ServiceNow. Order values that represent the order of input-fields are added to Variable Sets when performing a Service Import or a SaraAutoSync is executed.
Resolution
Update to a fix version listed below or a newer version if available.
Fix Status: Released
Fix Version(s): ServiceNow Service Connector (SNSC) 2.1.0 - Available ServiceNow Service Connector (SNSC) 2.0.1 - Available