ARA Execution start attempts failed and cannot be recoverable.
search cancel

ARA Execution start attempts failed and cannot be recoverable.

book

Article ID: 84994

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Affects Release version(s): 7;8

Error Message :
Execution start attempts failed and cannot be recoverable.

If attempting to increase the approval time out by setting either

<add key="GracePeriod" value="P1D" /> in ...\automic\Tools\ARA\WebUI\customer.config 

or 

<add key="GracePeriod" value="1440" /> in ...\automic\Tools\ARA\WebUI\customer.config

when the workflow is executed it requires approval.  If approval is given after 1 hour, the execution will be set to failed (Execution start attempts failed and cannot be recoverable).

<Please see attached file for image>

0EMb0000000IY6a.png

Environment

OS Version: N/A

Cause

Cause type:
Defect
Root Cause: Approved executions could not start due to incorrect grace period handling.

Resolution

Update to a fix version listed below or a newer version if available.

The Package is available for download at the Automic-Support-Zone (https://support.automic.com). 

Hotfix-Description: Incorrect behavior of approval grace-period 

After the execution is approved, it could not start because of incorrect grace period handling. The system now uses Approval System > Grace Period (customer.config) to determine if the execution should continue after being approved.


Fix Status: Released

Fix Version(s):
Release Manager 8.0.0 - Available
Release Manager 7.0.3 - Available

Additional Information

Workaround :
N/A

Attachments

1558693335619000084994_sktwi1f5rjvs16m6i.png get_app