SAP Agent frequently loses connection after entering New Years Day (12AM)
search cancel

SAP Agent frequently loses connection after entering New Years Day (12AM)

book

Article ID: 84987

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Error Message :
GSSException: Defective token detected (Mechanism level: input buffer wrong format)

At the Turn of the year 2017, SAP Agents lose connection to the SAP system. SAP Agents also fail to connect to the Automation Engine.The above error can be temporarily resolved with a keystore update (renew transfer key), which will allow agents to connect to the SAP system and the Automation Engine.  However, SAP Agents continue disconnecting every 11 minutes.
 
 

Environment

OS Version: N/A

Cause

Cause type:
Configuration
Root Cause: Use of an outdated Java version causes this error.

Resolution

At the beginning of the year 2017, there was a leap second that took effect. This occurrence in combination with an using an older Java version, 1.6.0 (which is no longer supported) causes the issue.

Upgrading to a newer supported Java version resolves this issue.


Fix Status: No Fix

Fix Version(s):
N/A

Additional Information

Workaround :
N/A