Filter on Task Status field is not filtering out Tasks
search cancel

Filter on Task Status field is not filtering out Tasks

book

Article ID: 8491

calendar_today

Updated On:

Products

Rally On-Premise Rally SaaS

Issue/Introduction

When applying the filter Task Status != Completed, the list still shows Tasks that are Completed.

 

Environment

Release:
Component: ACSAAS

Cause

Task Status is a field attached to a User Story that is based on the rollup of all the Tasks associated to the User Story. The field’s value will not be set to Completed unless all the Tasks in a User Story are in the Completed state.

In the example above, the value for the Task Status field remains In-Progress because there is still one Task In-Progress.

 

Resolution

When viewing a list, such as shown above, the filtered fields set are dependent upon the work item type being displayed in the list. In the above example, only fields on the User Story work item (HierarchicalRequirement in the Web Services API doc) are available to filter.

The Task Status field is a calculated field on the User Story work item that will always be:

  • “Defined” only if all Tasks are Defined
  • “Completed” only if all Tasks are Completed
  • “In-Progress” if one or more Task is In-Progress