NSK Agent disconnects after changing srvquery to 1
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Article ID: 84780
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Updated On:
Products
CA Automic Workload Automation - Automation Engine
Issue/Introduction
Error Message : U02000035 The Server '10.80.12.221' sent the status response after '0' minutes and '0' seconds.
Changing the parameter srvquery to a value of 1 in the ucsrv.ini file results in the NSK Agent losing connection to the Automation Engine. The above error is written to the Agent log.
Environment
OS Version: N/A
Cause
Cause type: Defect Root Cause: Changing srvquery=1 changes the behavior so that the Automation Engine (AE) isn't sending keep alive signals. The srvquery parameter of 1 can only be used for Agent's built by Automic in-house at the current time.
Resolution
Update to a fix version listed below or a newer version if available where additional functionality is planned to optimize Agent connectivity.
Fix Status: Released
Fix Version(s): Automation Engine 12.1.0 - Available
Additional Information
Workaround : 1. Edit ucsrv.ini and change srvquery=0 2. Restart each CP/WP 3. Start agent