Search of an Object on AWI produces duplicate or incorrect results for objects

book

Article ID: 84763

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Error Message :
Object view could not be loaded. Could not find the object. It may have been deleted or renamed.

In the Automic Web Interface (AWI), there is an issue where searching for an object will produce duplicate objects or objects that have previously been deleted.. When opening the duplicate object from AWI, the following error message is produced:


Stack:
======================================================================
BTA/LOCAL
MTLAE12: Client 100
Explorer

Search: VARA
VARA.BTA_DESC

Object view could not be loaded. Could not find the object. It may have been deleted or renamed.
Show Error Details

Name: VARA.BTA_DESC
Object view could not be loaded. Could not find the object. It may have been deleted or renamed.
Hide Details(Stacktrace)

Error during XRequest com.uc4.webui.communication.requests.GetObjectPropertiesAdaptercom.uc4.ecc.backends.exceptions.AutomationEngineAPIException
com.uc4.ecc.backends.util.APICallHelper.sendRequestAndWait(APICallHelper.java:57)

Cause

Cause type:
Other
Root Cause: The root cause is a possible corrupted indexCache directory which is located in /bin directory.

Environment

OS: All

Resolution

  1. Shut down the JWP 
  2. Clear the Search Cache (contents of the indexCache folder in bin directory of the engine) 
  3. Restart JWP 
  4. Wait until cache is re-built



Fix Status: No Fix

Fix Version(s):
N/A

Additional Information

Workaround :
N/A