Not all Connection Objects displayed in drop down menu for JMS Jobs

book

Article ID: 84729

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine AUTOMIC WORKLOAD AUTOMATION

Issue/Introduction

Error Message :
N/A

After performing an upgrade from Automation Engine (AE) version 9 to version v11.2.1 HF2, not all the connections are displayed under the Connection tab of a JMS receiver or a JMS sender Job object. 

<Please see attached file for image>

0EMb0000001UbFI.png
If the Connection drop down is selected, the Connection isn't listed and the object cannot be updated. 

<Please see attached file for image>

0EMb0000001UbFN.png

Note: This is only an issue when updating from Automation Engine v9 to v11.2.

 

Cause

Cause type:
Other
Root Cause: Due to a previous bug in AE v9, connection objects might have a template flag, even though they are not a template. These connection objects will be filtered out for JMS jobs. 

Environment

OS Version: N/A

Resolution

To see the invalid entries (Connection objects) run the below statement against the Automic database:

select oh_istemplate, oh.* from oh where oh_otype = 'CONN' and oh_istemplate = 1

To correct these invalid entries run the following statement manually.
 
UPDATE OH SET OH_ISTEMPLATE = 0 WHERE OH_ISTEMPLATE = 1 AND OH_OTYPE = 'CONN' AND OH_IDNR > 100000 AND OH_CLIENT > 0


Fix Status: No Fix

Additional Information

Workaround :
N/A
 

Attachments

1558692959604000084729_sktwi1f5rjvs16lwo.png get_app
1558692957608000084729_sktwi1f5rjvs16lwn.png get_app