JRM: Process stops when the APM setAppValue is not correct
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Article ID: 84666
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Updated On:
Products
CA Automic Service Orchestration - Automation Engine
Issue/Introduction
Affects Release version(s): 3
Error Message :
Field with name: *** could not be found in app
The JBoss for Request Manager (JRM) process stops after Automic's Package Managers (APM) setAppValue fails with the above message.
The expected behavior is to indicate the error and not to stop the process.
Cause
Cause type:
Defect
Root Cause: setAppValue APM throws an exception if a field name is not found in the form.
Environment
Release:
Component: ARQMGT
Resolution
Update to a fix version listed below or a newer version if available.
Fix Status: Released
Fix Version(s):
Request Management 3.3.1 - Available
Request Management 3.2.4 - Available
Request Management 3.1.7 - Available
Additional Information
Workaround :
N/A
Feedback
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Yes
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No