SLO executes the task set in Action more than once if fulfilled
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Article ID: 84635
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Updated On:
Products
CA Automic Workload Automation - Automation Engine
Issue/Introduction
Error Message : N/A
Service Level Objective (SLO) fulfillment is met more than once if the following conditions are met:
Fulfillment criteria is set similar to this:
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* In UC_CLIENT_SETTINGS, a maximum PROMPT_RESPONSETIME has been set. * The monitored task contains a PRPT and this PRPT is not filled within the limit defined in UC_CLIENT_SETTINGS / PROMPT_RESPONSETIME
Investigation
The issue may occur in a similar scenario:
1 - PROMPT_RESPONSETIME is set to '1' in UC_CLIENT_SETTINGS.
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2 - Start a task that contains a promptset. 3 - Don't fill in the promptset - wait until the prompt response time has lapsed. 4 - The script will be automatically canceled with "U00012104 PROMPT_RESPONSETIME of task '<TaskName>' (RunID '<RunID>') has been exceeded."
Results
Expected : SCRI.SEND.MAIL should be executed once.
Actual : SCRI.SEND.MAIL is executed twice.
20171215/115839.759 - U00012111 Script 'SCRI.LET.IT.TIMEOUT' (RunID '0001548023') terminated with CANCEL. 20171215/115839.812 - U00007000 'SCRI.SEND.MAIL' activated with RunID '0001549014'. 20171215/115839.856 - U00007000 'SCRI.SEND.MAIL' activated with RunID '0001549015'.
Cause
Cause type: Defect Root Cause: Unable to reproduce in version 12.0.4 and above.