Unable to launch Applications Manager v8 client after upgrading to Java 1.8_131
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Unable to launch Applications Manager v8 client after upgrading to Java 1.8_131

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Article ID: 84552

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

Error Message :
Error: unsigned application requesting unrestricted access to system the following resource is signed with a weak signature algorithm MD5withRSA and is treated as an unsigned: http://xxxx/x/x/groovy-all-1.7.10 _signed.jar

After upgrading client side Java to 1.8_131, users are unable to open the Application Manager version 8.0 client.

The following pop up is displayed after launching the application from the intro page:

<Please see attached file for image>

0EMb0000001QxAn.png

Selecting the details button shows the following:


<Please see attached file for image>

0EMb0000001QxAs.png
 

Environment

Release: AAMOS499000-8.0-Automic Applications Manager-OS400 Agent
Component:

Cause

Cause type:
Other
Root Cause: Application Manager (AM) 8 uses a legacy build with java 5. Java 1.8_121 + will block the client connection as AM 8 was built with an older version of java and older signature algorithm (MD5).

Resolution

Update to a fix version listed below or a newer version if available.

Fix Status: Released

Fix Version(s):
Applications Manager 9.0.0 - Available

Additional Information

Workaround :
Use an older version of Java pre-1.8_131 for the client side Java.
 

Attachments

1558704592644000084552_sktwi1f5rjvs16lnc.png get_app
1558704590553000084552_sktwi1f5rjvs16lnb.png get_app