AS/400 Agent freezes and normal operations not performed

book

Article ID: 84528

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine AUTOMIC WORKLOAD AUTOMATION

Issue/Introduction

Error Message :
N/A

An OS/400 Agent is up and running and is working normally, then it stops working and freezes.  It is no longer available for the Automation Engine.
 
The Agent does not reconnect to the Engine as expected. It’s also is not reconnecting when the Automation Engine is restated.
 
Investigation
  • The Agent process is still up and running at the OS level, status: SELW.
  • There are no new entries in the Agent’s log file.
  • In the trace file (TCP/IP=9) the following message block is written continuously:

    0000006B 20170802/153115.583 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153116.614 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153117.644 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153118.674 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153119.704 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153120.735 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153121.765 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153122.795 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153123.825 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153124.856 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153125.886 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153126.916 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153127.946 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153128.976 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153130.007 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153131.037 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153132.039 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153133.069 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153134.094 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153135.124 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153136.154 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153137.184 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153138.214 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153139.245 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153140.275 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153141.305 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153142.335 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153143.366 -           --> uc4::AgentContext::send(byte *, int)
    0000006B 20170802/153143.366 -           Potential Server List
    0000006B 20170802/153143.366 -           i = 0   ->10.19.2.130<-   2217
    0000006B 20170802/153143.366 -           i = 1   ->10.19.2.130<-   2218
 
 

Cause

Cause type:
Defect
Root Cause: The AS/400 Agent doesn't continue to process the KEEP-ALIVE mechanism.
So in cases where the connection aborts on a low socket level, it doesn't reconnect to the Automation Engine. This happens if the socket is closed in an improper way.

Environment

OS: IBM AS/400
OS Version: N/A

Resolution

Update to a fix version listed below or a newer version if available.

Fix Status: Released

Fix Version(s):
Component(s): Agent AS400

Automation Engine 12.1.1 - Available
Automation Engine 12.0.4 - Available

Additional Information

Workaround :
N/A