Banner Agent - Banner components not selecting parameters and printers from the correct agent
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Article ID: 84515
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Updated On:
Products
CA Automic Applications Manager (AM)
Issue/Introduction
Error Message : N/A
Banner components fail to select the correct parameters and printers from the correct Agent.
For example, the Banner Tab of a component that is assigned to Agent A, when selecting 'User Name' in the Parameter Set field, the Users listed is from Agent B instead of Agent A.
Stopping Agent B and having only Agent A running and repeating the test, we are thrown an "Unable to contact agent. Agent must be running to access data" error.
Note that both Banner Agent A and Banner Agent B, are running against the master's local agent.
There are multiple scenarios where this can occur.
Cause
Cause type: Defect Root Cause: The next version of the RA Framework (6.4.15, which will be included in AM 9.2.1), has the caching that caused this problem disabled, so the problem no longer occurs
Environment
OS Version: N/A
Resolution
Update to a fix version listed below or a newer version if available.
Fix Status: Released
Fix Version(s): Applications Manager 9.2.1 - Available
Additional Information
Workaround : Restart the Java Web Client before doing a search for a parameter that has a different agent from the previous search.