"RmiRegistryPortNumber not available" error starting RmiServer
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"RmiRegistryPortNumber not available" error starting RmiServer

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Article ID: 84508

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

Attempting to start the Applications Manager (AM) processes results in the following error message in the RmiServer log.

ErrorMsg: AwE-5125 No port available 
Details: RmiRegistryPortNumber not available 1099 
java.lang.RuntimeException 
at com.appworx.server.data.AxRmiServer.main(AxRmiServer.java:893) 

Environment

Applications Manager 9.3x, 9.4x, 9.5x

Cause

This error is usually caused if the RmiServer port defined is used by another process or custom SSL certificates for Connection Authentication are missing.

Resolution

Change the RmiRegistry port in the $AW_HOME/web/classes/Options.properties file to another unused port number, and restart the AM processes.

If error persists, check if you are using Custom SSL Certificates for Connection Authentication

With version 9.3.3 and higher, You must use a custom SSL certificate for connection authentication by creating user_keystore  and user_keystore_config  files on the Automation Engine machine as well as every remote agent and client machine. Using your own certificate prevents unauthorized connections between connection endpoints.

See documentation link below for details:


https://techdocs.broadcom.com/us/en/ca-enterprise-software/intelligent-automation/applications-manager/9-3/Installation_Guide/Applications_Manager_Installation_Advanced_Topics/Using_Custom_SSL_Certificates_for_Connection_Authentication.html