Sysload Agent no longer collects after reaching the maximum number of disks (physical or logical)

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Article ID: 84489

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Updated On:

Products

CA Automic Sysload

Issue/Introduction

Affects Release version(s): 5

Error Message :
In sldrmd.log:
DD MM HH MM:SS YYYY: [LPtrVerif] OAgNtPhysicalDisc.c[1181] - Error
DD MM HH MM:SS YYYY: [LPtrVerif] OAgNtPhysicalDisc.c[585] - Error

The agent sets the max values of physical / logical drives at startup.
If Collector discovers new disks and the maximum number of disks being reached, the following messages "[LPtrVerif] OAgNtPhysicalDisc.c[1181] - Error " appear in the sldrmd.log:

Cause

Cause type:
By design
Root Cause: At startup, the Sysload agent sets the default maximum values for the Number of Physycal and Logical Disks to the current value + 3.
Sometimes, for example for backup purposes, more than three disks are added to the system which provokes the agent to stop collecting as it reaches the limits.

Environment

OS: All

Resolution

  1. Stop the agent
  2. Edit the Collector's configuration file
  3. Manually add the value of the parameters "Nb_PDisk" and "Nb_LDisk" in the section PARAM adding  these kind of lines for 20 physical disks and 50 logical disks:
[PARAM] 
Nb_PDisk=20
Nb_LDisk=50
  1. Restart the agent


Fix Status: No Fix

Additional Information

Workaround :
N/A