Job fails with Invalid password error after properly updating the Oracle login objects' username/password

book

Article ID: 84473

calendar_today

Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

Error Message :
ORA-01017: invalid username/password

In Applications Manager version 8.0.13 or later, after properly changing an Oracle login object, jobs using the object fails with an invalid username/password error.

A "check" on the login object results in a successful connection.


 

Cause

Cause type:
By design
Root Cause: Due to previous changes to Oracle connection pools, username/passwords are cached, which triggers the error when a password is changed.

Environment

OS Version: N/A

Resolution

Update to a fix version listed below or a newer version if available.

Fix Status: In Progress

Fix Version(s):
Applications Manager 9.2.0 - Available

Additional Information

Workaround :
Restart Applications Manager's RmiServer process.