ARA workflow goes into Inactive status even though it contains Deployment Descriptor

book

Article ID: 84453

calendar_today

Updated On:

Products

CA Continuous Delivery Automation - Automation Engine

Issue/Introduction

Error Message :
U00007068 Task 'RM.GENERAL.STAGE_BUILD' (Lnr: '0002') has been set to inactive because it cannot be found in the Deployment Descriptor.

An ARA workflow contains a Deployment Descriptor.  However, it is still getting this error in the Activation report:
U00007068 Task 'RM.GENERAL.STAGE_BUILD' (Lnr: '0002') has been set to inactive because it cannot be found in the Deployment Descriptor.

Investigation
Go to the workflow's History Records.

(Release Automation tab > Monitoring > highlight the workflow > in the Details pane on the right, click on 'Show History Records')

<Please see attached file for image>

0EM0N000001hl6I.png


Download the Deployment Descriptor report from the workflow's History Records.

<Please see attached file for image>

0EM0N000001hl6N.png




 

Cause

Cause type:
Configuration
Root Cause: When another Component ("COM2") is added in to the Workflow ("WF") that's also mapped to the same Target, the new Component ("COM2") becomes inactive because it is using the same Package ("PK") and Profile ("PRO") upon execution.

Environment

OS Version: N/A

Resolution

To correct this issue, a new Package ("PK2") needs to be created whenever there is a new Component ("COM2") because the original Package ("PK") will not have any information about the new Component ("COM2") since the original Package ("PK") only has information about the original Component ("COM").

<Please see attached file for image>

0EM0N000001hl6S.png

Fix Status: No Fix

Fix Version(s):
N/A

Additional Information

Workaround :
N/A

Attachments

1558704291934000084453_sktwi1f5rjvs16lin.png get_app
1558704290116000084453_sktwi1f5rjvs16lim.png get_app
1558704288004000084453_sktwi1f5rjvs16lil.png get_app