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Agents and CallAPI does not connect to any other CPs if the first CP is a JCP
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Article ID: 84435
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Updated On:
Products
CA Automic Workload Automation - Automation Engine
Issue/Introduction
Error Message : This is just a short excerpt from the logs after for example a new agent was started with no entry in section: [CP_LIST] ... 20170928/103109.167 - U02000004 Connection to Server 'AUTOMIC#CP001' successfully created. 20170928/103109.167 - U03000009 Partner is not a communication process (CP) 20170928/103109.168 - Failed to connect to any CP. ...
If an Agent is started in verson 12.1 with a Java Control Process (JCP) as the first communication process instead of as a normal Communicaiton Process (CP), new Agents (which have no entry in the section [CP_LIST]), or CALL API'x are not able to connect to the Automation Engine (AE).
Cause
Cause type: Defect Root Cause: This happens because the socket connection to the JCP is successfully established, but no messages can be sent. The CP Port is blocked by the first started JCP.
Environment
OS Version: N/A
Resolution
Update to a fix version listed below or a newer version if available.
Fix Status: Released
Fix Version(s): Component(s): Automation Engine and Initial data
Automation Engine 12.1.0.HF4 – Available
Additional Information
Workaround : Stop the JCP and CP processes and start the CP first.