Activities record is not being set to Ended, but the Statistics record is.

book

Article ID: 84394

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine AUTOMIC WORKLOAD AUTOMATION

Issue/Introduction

Error Message :
N/A

The Activities record is not being set to Ended, but the Statistics record is.

Results
Actual:  Jobs were being shown as ended in the Statistics window and as still active in the Activities window.
Further investigation into this issue revealed massive DEADLOCKs simultaneously with the EH records not being set to Ended.
 
Expected: Both Statistics as well as Activities windows, should display the same status for jobs.

Cause

Cause type:
Configuration
Root Cause: Database settings not configured correctly, which lead to database deadlocks.

Environment

OS Version: N/A

Resolution

  1. Ensure that MS SQL Server Versioning/Snapshot Isolation is turned on. 
  1. The option tcp_nodelay must be set to '1' in the ucsrv.ini for the Automation Engine. 
It defines the use of the Nagle algorithm for the connections of the Automation Engine. 


Fix Status: No Fix

Fix Version(s):
N/A

Additional Information

Workaround :
N/A