Can not start Tomcat
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Can not start Tomcat

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Article ID: 8389

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Updated On:

Products

CA Spectrum

Issue/Introduction

We are trying to start Tomcat using the starttomcat.sh script but are getting an error: 

./tomcat/bin/startTomcat.sh 

 

Process Daemon disconnected: 

 

The .hostrc file on the machine of the process daemon you connected 

to does not contain your hostname and / or your username. 

 

Starting Tomcat 

Error obtaining install ticket for TOMCAT 

Processd error attempting to start TOMCAT install ticket 

 

Process Daemon disconnected: 

 

The .hostrc file on the machine of the process daemon you connected 

to does not contain your hostname and / or your username. 

 

We have checked the .hostrc files and they are correct. What else coould be the problem? 

Environment

Release:
Component:

Cause

Its possible that user Group settings are incorrect on this machine preventing ProcessD from being able to start its Tickets - namely TOMCAT.idb and MYSQL.idb

Check the processd_log for more details on the issue

<SPECROOT>/lib/SDPM/processd_log

 

You may see errors similar to the one shown below: 

Oct 13 10:36:48 Can't start new ticket: TOMCAT, because the group id for: spectrum is invalid 

Oct 13 10:36:48 Can't start new ticket: MYSQL, because the group id for: spectrum is invalid 

Oct 13 10:36:48 Failure to connect to Location Service at host: 

localhost, port #: 56063. 

Will try again until we make a connection. 


Oct 13 10:37:50 Failure to send heartbeat message 

Oct 13 10:39:14 
Client Name: cmd test program 
User Name : spectrum( -1 ) 
Host : localhost( 127.0.0.1 ) 
Authorized : Failed user/group validation 


Oct 13 10:39:14 
Client Name: install partname startup program 
User Name : spectrum( -1 ) 
Host : localhost( 127.0.0.1 ) 
Authorized : Failed user/group validation

Resolution

- Check the etc/group file for proper user group settings.



- You can check etc/group files on the other Servers and compare the results.



- Verify proper User and Group settings with your network team



Once User Group settings are verified to be correct, try starting Tomcat again. 

Additional Information

General Info on etc/group files: 

 

https://www.cyberciti.biz/faq/understanding-etcgroup-file/