search cancel

lisa-invoke url returns error after Registry restart

book

Article ID: 8387

calendar_today

Updated On:

Products

CA Application Test CA Continuous Application Insight (PathFinder) Service Virtualization

Issue/Introduction

When lisa-invole url is hit to execute a test case/suite, below error is thrown:

<message>An error occured in 'runTest'. Message: currentProjectManager is null! Fix this by calling ProjectManager.setCurrentProjectVersion() first! 
Stack: java.lang.NullPointerException: currentProjectManager is null! Fix this by calling ProjectManager.setCurrentProjectVersion() first!
at com.itko.lisa.repo.ProjectManager.getInstance(ProjectManager.java:259)
at com.itko.lisa.model.mar.ModelArchiveInfo.createTestMARInfo(ModelArchiveInfo.java:218)

Cause

After investigation, it was found that this error is thrown when the stagingDocument path  was not added to the lisa-invoke url. It is indirectly indicated by the nullPointerException

Environment

All supported DevTest releases and platforms.

Resolution

This error can be resolved by providing the stagingDocumentPath to the lisa-invoke url. 

 

Additional Information

For more information refer to DevTest Solutions documentation for the release you are on:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/devops.html

See section LISA Invoke API