AD Endpoint shows incorrect encoding for Spanish character

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Article ID: 8376

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Risk Analytics CA Secure Cloud SaaS - Arcot A-OK (WebFort) CLOUDMINDER ADVANCED AUTHENTICATION CA Secure Cloud SaaS - Advanced Authentication CA Secure Cloud SaaS - Identity Management CA Secure Cloud SaaS - Single Sign On

Issue/Introduction

Problem with the Active Directory and Oracle endpoints 

Both are showing incorrect encoding character (ñ) into the last name field. 

The Global User names  are  Spanish, Latin American names. 

Cause

Custom code reading the data from Oracle Table and sending the lastname value encode in ANSI to ADS and Oracle Endpoint which display unreadable character value.

 

Environment

IDMGRProduct Release =12.6Problem with the Active Directory and Oracle endpoints Both are showing incorrect encoding character (ñ) into the last name field. The Global User names are Spanish, Latin American names.

Resolution

Customer changed the custom code to use encode in UTF-8 instead ANSI.

Additional Information

https://docops.ca.com/ca-identity-manager/12-6-8/EN/configuring/user-console-design/ca-identity-manager-localization/how-to-configure-support-for-localization/change-the-jboss-server-xml