VMware probe reports Self-monitoring failures for Provisioned Space in some Data Stores.
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VMware probe reports Self-monitoring failures for Provisioned Space in some Data Stores.

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Article ID: 8366

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

vmware probe Self-Monitoring alarms are created for some data stores.

Self-Monitoring Failures for '<***.<data store>.ProvisionedSpace'. Data Collection (* of * failed).

 

Other data stores on the same vCenter and being monitored by the same probe report the data as expected.

Environment

UIM 8.51

vmware probe 8.63

Cause

You might see similar error messages in the vmware probe log as follows:

[Data Collector - ****, vmware] Failed to collect data for monitor '***.Provisioned Space'. Updated value will not be available.: Lookup failed for value of monitor '"***:<data store name or ID>"."ProvisionedSpace"'. GUI will not display current value or severity. Will try again next polling cycle.

The above logs are seen for monitors whose value was not found in the vCenter and probe sets the value to null. This needs to be checked at the vCenter why the value was missing.

ProvisionedSpace is calculated using the following 3 values from vCenter: 

summary.capacity + summary.freeSpace + summary.uncommitted for a datastore.


Out of these three, summary.uncommitted is sometimes not set in the vCenter.

Thus, probe cannot calculate the value of the monitor and the value is set to null.

For this particular scenario, you can set the key value_if_datastore_uncommitted_space_is_unset = 0 in setup section of vmware.cfg file and restart the probe.


The probe will use this value for summary.uncommitted and  calculate the value of the monitor 'ProvisionedSpace'.
If any of these values is invalid or not returned to the probe then you might see the Self-Monitoring alarms.

An example of invalid value is when 'uncommitted' returns 'unset' instead of a number.

Resolution

If you are unable to determine the root cause of the missing/invalid data on your VMware system you can disable the Self-Monitoring alarms or change their severity.

See How to deactivate CA UIM self-monitoring alarms for instructions.

Additional Information

You can use the VMware Managed Object Browser (MOB) to check the values in the system.

See Vmware probe - tips for troubleshooting some common vmware problems / alarms or consult third party documentation for reference.