Some Roles are unable to see the xFlow Analyst Interface option under the Administration Menu Tree
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Some Roles are unable to see the xFlow Analyst Interface option under the Administration Menu Tree

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Article ID: 8313

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Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Specific roles are not able to see the xFlow Analyst Interface option under the Administration tab.

Environment

CA Service Desk Manager 17.1 and higher.

Cause

The main cause for this behavior can stem from the Role's Web Form Detail.

This can also cause other options to not be available as well.

Resolution

Verify the Web Form Detail Resource used for a good Role vs bad.

For example if the System Administrator Role is able to see specific options but the Administrator Role is not, browse to the following location in the SDM UI:

Administration tab-> Security and Role Management-> Role Management-> Role List-> 

Select the Administrator Role-> Resources-> Tabs-> Select Administration tab with full menu tree-> 

Then select the link under Starting Page

Here under Resource compare this to a working Role, the default Resource for the Administration Role should be set to:

$cgi?SID=$SESSION.SID+FID=123+OP=DISPLAY_FORM+HTMPL=admin_main_role.htmpl+KEEP.tree_code=admin_tree

Modify this accordingly, refresh the browser, and the options available to that specific Role should now match the other compared Role.