Getting "memory accessed out of range" error when trying to start an RDP session.
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Getting "memory accessed out of range" error when trying to start an RDP session.

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Article ID: 8312

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Updated On:

Products

CA Privileged Access Manager - Cloakware Password Authority (PA) CA Privileged Access Manager (PAM)

Issue/Introduction

  • I'm getting a java error when I try to connect remotely to a windows server.
  • I'm able to connect remotely (mstsc) from my own desktop. 
  • PAM RDP Access Method is not configured to autologin. 
  • When Session Recording is enable, it also shows the error message:
    "Can not process connect request. Probably security settings at remote server are too high. Deleting the file: XXXX-0000038235-20170829110708458_RDP" 
  • When Session Recording is disabled, the security settings error is not displayed in the session logs, but the java error: "memory accessed out of range" message keeps displaying.
    Error type: ArrayIndexOutOfBoundsException.
    Error message: memory accessed out of Range!.
  • I reboot the destination server and the issue persist.

Environment

Releases: 
CA PAM 2.x
CA PAM 3.x

Cause

This is caused by a server security setting that has to be modified in the GPO.

 

Resolution

Edit the Destination Server GPO.



  1. Open the gpedit.msc
  2. Expand the Computer Configuration >> Administrative Templates >> Windows Components >> Remote Desktop Services >> Remote Desktop Session Host >> Security
  3. Enable the "Require use of specific security layer for remote (RDP) connections" settings.



Note: For immediate changes, If the GPO is edited by a global GPO, then you need to refresh the changes in the destination servers:



  1. Login to the server, Ctrl + R and enter "gpupdate".