TDM Portal error trying to register objects
search cancel

TDM Portal error trying to register objects

book

Article ID: 8286

calendar_today

Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

When trying to register an XML file in the TDM Portal  ("Modelling" > "Objects" > "Register" ),  nothing happens.   

When I open the menu "Modelling" > "Objects" and click on the "Refresh" button,  I get the error "The server is not reachable. Could not perform the action".

Is there a way I can resolve this issue?

Environment

Windows: non-English locales

Cause

The issue is that the parser is expecting a locale of EN_US (English,US) as the default locale for the TDM Portal.  When registering objects in the modelling section of the portal with non-English machines,  the portal will fail silently,  or a generic error message will indicate that the server is not available,  since the server is trying to parse an internal English descriptor file as non-English.

Resolution

If you are working with a locale other than English,  you will need to add the following property to your wrapper.conf file (default location is C:\Program Files\CA\CA Test Data Manager Portal\service\conf\wrapper.conf)

wrapper.lang=en_US 

Once you save the setting and restart the portal,  you should now be able to register your object successfully.