CA PPM 15.3: Unable to run a Jaspersoft Report from Reports and Jobs menu

book

Article ID: 8283

calendar_today

Updated On:

Products

CLARITY PPM FOR ITG CLARITY PPM FEDERAL Clarity PPM SaaS - Application Clarity PPM On Premise

Issue/Introduction

Upon attempt to run a Jaspersoft report from the Report and Jobs page, the following error is received:
RPT-0020: Error occurred while downloading the report Data Warehouse Schema. Please contact your system administrator 

 

Cause

This issue is resolved by applying the cumulative Jaspersoft patch:
JASPERSOFT SERVER CUMULATIVE PATCH 6.2.1_5.2.1.4 FOR CA PPM 14.3, 14.4,15.1,15.2 AND 15.3

DVD500000000000371.iso

For SaaS customers, the latest Jaspersoft version is 6.4, therefore make sure all end-users have the latest version of Jaspersoft Studio.

Environment

Release: 451-101-15.3-Clarity-Creator User License
Component:

Resolution

1.Check version of jaspersoft via by entering the following URL
http:<server>/reportservice/version.html

2. Verify the version is not on the latest cumulative patch:

JaaS Release Version = 2.2.1
JaaS Build Number = 54
JasperSoft Version = JasperReport Server 6.2.1 Enterprise (20160322_0602)
CA PPM Jaspersoft Release Version = 5.2.1
CA PPM Jaspersoft Build Number = 54

3. After installing the patch, the updated version is:

JaaS Release Version = 2.2.1
JaaS Build Number = 54
JasperSoft Version = JasperReport Server 6.2.1 Enterprise (20160322_0602)
CA PPM Jaspersoft Release Version = 5.2.1
CA PPM Jaspersoft Build Number = 54
CA PPM Jaspersoft Release Patch Version = 5.2.1.4
CA PPM Jaspersoft Patch Build Number = 33