CA ActiveMQ Broker service fails to start
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CA ActiveMQ Broker service fails to start

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Article ID: 8279

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Updated On:

Products

CA Privileged Access Manager - Server Control (PAMSC) CA Privileged Identity Management Endpoint (PIM)

Issue/Introduction

Sometimes the service "CA-PIM-ActiveMQ-Broker" fails to startup.

Retrying to startup may or may not work.

 

C:\ActiveMQ\logs\wrapper.log is indicating

...

STATUS | wrapper | 2017/09/21 10:16:17 | Launching a JVM...
INFO | jvm 2 | 2017/09/21 10:16:17 | WrapperManager: Initializing...
INFO | jvm 2 | 2017/09/21 10:16:38 | WrapperManager Error: Failed to connect to the Wrapper at port 32,000. Cause: java.net.ConnectException: Connection timed out: connect
INFO | jvm 2 | 2017/09/21 10:16:38 | WrapperManager Error: Exiting JVM...
ERROR | wrapper | 2017/09/21 10:16:39 | JVM exited while loading the application.

...

Environment

Release:12.8 / 12.9
Component: SEOSNT

Cause

We have seen this issue in environments where the server was very loaded and CPU utilisation was high.

Resolution

Place the following parameter at the very bottom of the file

C:\ActiveMQ\bin\wrapper.conf

...

wrapper.backend.type=PIPE

Additional Information

For additional details please see:

https://wrapper.tanukisoftware.com/doc/english/prop-backend-type.html

(note this is a link to a 3rd Party which CA /Broadcom does not take any liability for)

 

To enable debugging on the Wrapper and on ActiveMQ set in

wrapper.conf
...
# wrapper.debug=TRUE
...

and
log4j.properties
...
#log4j.logger.org.apache.activemq=DEBUG
...

 

and collect the files

 

C:\ActiveMQ\logs\wrapper.log

C:\ActiveMQ\data\activemq.log