JasperReports 6.3 - LDAP users cannot login after Re-Deploy
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JasperReports 6.3 - LDAP users cannot login after Re-Deploy

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Article ID: 8244

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Updated On:

Products

CA Spectrum

Issue/Introduction

After running a Re-deploy in Jasper Integration page in OneClick, the LDAP users are no longer able to login on JasperReports.

Environment

Spectrum 10.2.1 and JasperReports 6.3
Spectrum 10.2.3 and JasperReports 6.3

Cause

Users are getting sync from Spectrum after re-deploy even though LDAP is configured in Jasper server.

Resolution

This issue has been addressed in the following patches: Spectrum_10.02.01.PTF_10.2.158, and Spectrum_10.02.03.PTF_10.2.324

Please contact CA Spectrum Support for a copy of the required patch.

Note:
  • For customers running Spectrum 10.2.1 or 10.2.2, that are planning to upgrade to Spectrum 10.2.3. If you have not already applied the Spectrum_10.02.01.PTF_10.2.158 patch, you can upgrade directly to Spectrum 10.2.3, and apply the Spectrum_10.02.03.PTF_10.2.324 patch without issues.

 

  • For customers that are running Spectrum 10.2.1 that have already applied the Spectrum_10.02.01.PTF_10.2.158 patch. If you are planning to upgrade to Spectrum 10.2.2, or Spectrum 10.2.3, there is a known anomaly you need to be aware of. In this scenario, Spectrum Report Manager will not start and there will bee errors found in t he tomcat log containing "devicemodule table alter query".

To get around this anomaly:

  1. On then OneClick SRM server's $SPECROOT/mysql/data/reporting database.

  2. Check the 'devicemodule' table to see if it contains the 'physical_index' column.

  3. If the 'physical_index column is not found, we need to update the schema by running the following query: Delete from schemaversion where name = 2011;

  4. Restarting tomcat after the change is made, will cause the schema version will be updated, and SRM will run.

    For further questions or concerns, please contact CA Spectrum Support.