Peforming an LDAP Directory Search returns no results
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Peforming an LDAP Directory Search returns no results

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Article ID: 8217

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

 

When I do a LDAP Directory Search from the ServiceDesk Web Interface (New Contact from LDAP - LDAP Directory Search), I get an incorrect display. The list of LDAP users is displayed empty although the counter indicates that  LDAP users have been found.

See screenshot :

<Please see attached file for image>

ldap_2_1.png

 

In this screenshot, the counter indicates that 2 ldap users have been found (matching the Ldap search criteria) , but none is displayed in the list.

Additionally, it has been confirmed that the pdm_ldap_test and pdm_ldap_import commands are working correctly, so, ServiceDesk-LDAP integration setup in option manager is working.

 

Environment

Release: SDMU0M99000-14.1-Service Desk Manager-Full License
Component:

Cause

This issue can be caused by unneeded spaces in the ldap variables NX_LDAP_DN and/or NX_LDAP_SEARCH_BASE.

In this example, we can see in the NX.env file:

@NX_LDAP_DN=CN=Administrator, CN=Users,  DC=mydomain1,  DC=com

@NX_LDAP_SEARCH_BASE=DC=mydomain1,  DC=com

Resolution

 

Removing the unneeded spaces from the variables to resolve the problem.

Here is an example of how the ldap variables should be:

@NX_LDAP_DN=CN=Administrator,CN=Users,DC=mydomain1,DC=com

@NX_LDAP_SEARCH_BASE=DC=mydomain1,DC=com

 

This change should be performed by updating correctly the variables through the Option Manager, and the changes will take effect in the following ServiceDesk service restart.

 

 

Attachments

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