CA Performance Center Services crashing
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CA Performance Center Services crashing

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Article ID: 8210

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

The Performance Center console service on the CAPC system is crashing. 

Environment

Release: IMDAGG99000-2.8-Infrastructure Management-Data Aggregator
Component:

Cause

The cause of these crashes was due to having too many connections to the mysql database and causing java exceptions and errors. Below are the exceptions and errors seen: 

org.springframework.jdbc.CannotGetJdbcConnectionException: Could not get JDBC Connection; nested exception is com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link fail

The last packet successfully received from the server was 21,250 milliseconds ago. The last packet sent successfully to the server was 17 milliseconds ago. 

ERROR | wrapper | 2017/08/30 14:23:48 | Shutdown failed: Timed out waiting for the JVM to terminate. 

ERROR | wrapper | 2017/08/30 14:23:48 | JVM did not exit on request, termination requested. 

STATUS | wrapper | 2017/08/30 14:23:48 | JVM received a signal SIGKILL (9). 

STATUS | wrapper | 2017/08/30 14:23:48 | JVM process is gone. 

STATUS | wrapper | 2017/08/30 14:23:48 | JVM exited after being requested to terminate. 

 

Resolution

In the file  /opt/CA/PerformanceCenter/PC/webapps/pc/WEB-INF/cfg/portal.console.properties increase the variable dbMaxActive in increments of 20, testing to validate between each raise to ID the correct value.