CAPKI Errors when starting SpectroServer
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CAPKI Errors when starting SpectroServer

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Article ID: 8209

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

When trying to start the SpectroSERVER via command line by the following: 

/opt/Spectrum/bin/StartSS.pl

We see an error output to the screen: 

Could not open CAPKI shared library, errno is 0, errmsg is /opt/CA/SharedComponents/CAPKI/CAPKI5/Linux/amd64/ 

64/lib/libcapki.so: cannot open shared object file: Permission denied 

From what we can tell, the Server still runs OK without issue. However these errors are confusing to see on Server StartUp and would like to have them removed. 

Environment

Release: All Supported Releases

Component: SPCCSS - SpectroSERVER Core

Cause

Upon Spectrum Installation, some permissions on Symbolic Links (symlink) are added to CAPKI files. 

We have seen in some situations where if a TAR backup is made of the /opt/Spectrum directory and at some point restored, the Symlink permissions on /opt/CA/Shared Components/CAPKI files may be broken. 

 

Resolution

1. Check the permissions on /opt/CA directory.
    The read (r) and execute (x) permissions should be granted to Other users

drwxr-xr-x. 3 root     root     4096 Mar 18  2022 CA

   The same permissions should be set to each directory in the path (/opt/CA/SharedComponents/CAPKI/CAPKI5/Linux/amd64/64/lib/libcapki.so)

   You can make sure of that running next from /opt

# sudo chmod -R 755 CA

   by the way /opt should also have read and execute permissions for Other users.

2. If the problem persists, the recommended resolution is to reinstall Spectrum on top of itself to reset the CAPKI Symlink permissions. After reinstalling Spectrum, the CAPKI permission denied errors should no longer appear.