Receiving CA XCOM error message TXPI primary code 0211 TXPI secondary code 3425 sending to server

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Article ID: 8205

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Updated On:

Products

CA XCOM Data Transport CA XCOM Data Transport - Windows CA XCOM Data Transport - Linux PC CA XCOM Data Transport - z/OS

Issue/Introduction

When sending a transfer to a remote server, the following error codes are returned:

TXPI primary code 0211 TXPI secondary code 3425  

Cause

TCPIP returned this error code to XCOM and it means "the destination socket refused an attempted connect operation".  This indicates that TCPIP could not make a connection to the remote server at all.

Environment

Release:
Component: XCUHP9

Resolution

The transfer did not make a connection to the remote XCOM.  There will be no entries in the xcomlog in the partner side.  It will be necessary to troubleshoot this problem by considering the following:

  1. Can you ping the new remote server? 
  2. Is XCOM up and running on that new server? 
  3. Is there a firewall? 
  4. Do you have the right address for the new server?  Are you specifying the right ipport for the remote server?
  5. Perform a loopback transfer on the remote server to ensure that it is working properly
  6. DNS problem

Additional Information

Still having problems?  Contact CA Support for assistance.