Login in a new installation may fail: AHD04407:.. html generation error. Could not find or process 'login.html' AHD04714: Unable to open file login.htmpl at ?: No such file or directory (2)
search cancel

Login in a new installation may fail: AHD04407:.. html generation error. Could not find or process 'login.html' AHD04714: Unable to open file login.htmpl at ?: No such file or directory (2)

book

Article ID: 8198

calendar_today

Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

After a new Service Desk Manager installation, when a user connects to the Service Desk UI, the following error messages could be displayed:


AHD04407: CA Service Desk Manager html generation error. Could not find or process ‘login.html’

AHD04714: Unable to open file login.htmpl at ?: No such file or directory (2) userid=

 

Following error is seen in the STDLOG file:


AHD04714: Unable to open file login.htmpl at ?: No such file or directory (2) userid=

 

The *.HTMPL files in the NX_ROOT\bopcfg\www\htmpl subfolders are not present.

Environment

Service Desk Manager

All supported releases and Operating Systems

Cause

The login errors are due to the *.HTMPL files not bring created in the following folders:


NX_ROOT\bopcfg\www\htmpl\default

NX_ROOT\bopcfg\www\htmpl\pda\analyst

NX_ROOT\bopcfg\www\htmpl\web\analyst

NX_ROOT\bopcfg\www\htmpl\web\customer

NX_ROOT\bopcfg\www\htmpl\web\employee

 

Resolution

One possible solution could be the uninstall and re-install of the Service Desk Manager application.


Another possibility is that considering the PDM_CONFIGURE process should rebuild the HTMPL files, using the content of the TAGGED and XML subfolders, the following approach can be taken:


1.  Verify that the XML and TAGGED sub-directories under the following folders exist and contain files:


NX_ROOT\bopcfg\www\htmpl\default

NX_ROOT\bopcfg\www\htmpl\pda\analyst

NX_ROOT\bopcfg\www\htmpl\web\analyst

NX_ROOT\bopcfg\www\htmpl\web\customer

NX_ROOT\bopcfg\www\htmpl\web\employee


2.  If so, open the NX_ROOT\site\config.properties file with a text editor and make the following changes:

a.  Search for the ‘resources.created’ parameter

b.  If it is set to ‘1’, change it to ‘0’ in order to have resources.created=0

c.  Save the changes to the file


3.  Re-run the PDM_CONFIGURE process


4.  After PDM_CONFIGURE has completed, please verify that there are HTMPL files in the following directories:


NX_ROOT\bopcfg\www\htmpl\default

NX_ROOT\bopcfg\www\htmpl\pda\analyst

NX_ROOT\bopcfg\www\htmpl\web\analyst

NX_ROOT\bopcfg\www\htmpl\web\customer

NX_ROOT\bopcfg\www\htmpl\web\employee

Additional Information

The resource.log file, placed in the NX_ROOT\log folder, provides details about the creation of the HTMPL files