The Business Hours are displayed incorrectly in Jasper 6.3 Spectrum Reports

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Article ID: 8141

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Updated On:

Products

CA Spectrum

Issue/Introduction

CA Spectrum Availability Group Report is showing incorrect Business Day End hours

Cause

When logged in to CABI 6.3 and setting up the Business Hours in an Availability Group Report, the "Input Controls" are showing Business Day Start with 08:00:00 and Business Day End with 17:00:00:

<Please see attached file for image>

CABI_Jasper_Business_hours_parameter.PNG

But the result report is showing for "Business Day End" here "05:00:00 AM" instead of "05:00:00 PM":

<Please see attached file for image>

CABI_Jasper_Business_hours_report.PNG

Environment

Spectrum 10.2.xCABI 6.3 (Jaspersoft)

Resolution

This is not seen, when you login with the "superuser" and is not showing in all environments.

A possible workaround for this is to create a schedule for this report.

 

From Spectrum 10.2.2 we are going to have the Unified CABI report structure. Additional code changes were added to fix this Issue. Unfortunately those changes are not compatible to 10.2.0 and 10.2.1 reports.

Additional Information

Spectrum 10.2.2 is scheduled for the second half of 2017.

Attachments

1558708733400000008141_sktwi1f5rjvs16r6y.png get_app
1558708729362000008141_sktwi1f5rjvs16r6x.png get_app