search cancel

Error: Failed to create agent configuration FWS Failing to initialize

book

Article ID: 8046

calendar_today

Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) CA Single Sign-On SITEMINDER CA Single Sign On Federation (SiteMinder)

Issue/Introduction

 

Federation Web Services (FWS) is failing to initialize with the below error in the affwebservices.log.

The environment variables are sourced correctly and the path to the Web Agent Option Pack (WAOP) bin directory is the first entry in the LD_LIBRARY_PATH.

Having restarted the Application Server, the issue persists.

affwebservices.log:

[2120/2540300032][Thu Jul 27 2017 15:57:55][agentcommon][INFO][sm-FedClient-00010] sm-FedClient-00010 (The SiteMinder Agent is initializing ..)

[2120/2540300032][Thu Jul 27 2017 15:57:55][agentcommon][INFO][sm-FedClient-00010] sm-FedClient-00010 (SiteMinder Product Details: PRODUCT_UPDATE=0000 , PRODUCT_NAME=Federation Web Services, PRODUCT_LABEL=142, PRODUCT_VERSION=12.52.)

[2120/2540300032][Thu Jul 27 2017 15:57:55][agentcommon][INFO][sm-FedClient-00010] sm-FedClient-00010 (Administration Manager is trying to create configuration for the SiteMinder Agent)

[2120/2540300032][Thu Jul 27 2017 15:57:55][agentcommon][INFO][sm-FedClient-00010] sm-FedClient-00010 (Creating agent connection using file : /opt/CA/webagent_optionpack/config/WebAgent.conf)

[2120/2540300032][Thu Jul 27 2017 15:57:59][FWSAdministrationManager.java][ERROR][sm-FedClient-00050] sm-FedClient-00050 (Failed to create agent configuration for : /opt/CA/webagent_optionpack/config/WebAgent.conf)

[2120/2540300032][Thu Jul 27 2017 15:57:59][FWSAdministrationManager.java][ERROR][sm-FedClient-00060] sm-FedClient-00060 ()

[2120/2540300032][Thu Jul 27 2017 15:57:59][ManageNameIDService.java][INFO][sm-FedClient-01520] sm-FedClient-01520 (NameID Management)

Environment

 

Policy Server 12.52.x on Windows 2008R2;
WA/WAOP 12.52.x on RedHat 6 64bits;

 

Cause

 

Below are two reasons that could be the cause of the problem.

  1. If WAOP environment variables are not set correctly.
  2. If the shared secret from the SmHost.conf is corrupted, Policy Server doesn't recognize it.

Resolution

 

Please follow the below steps to resolve the issue.

  1. Please manually set the Web Agent Option Pack WAOP environment variables by running the script and restarting the application server.
  2. Re-register the Web Agent Option Pack (WAOP)
  1. Delete trustedHost within AdminUI;
  2. Re-register the Web Agent Option Pack back with the Policy Server;
  3. Restart services;