Policy Validation Results in, "Unable to retrieve service properties"
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Policy Validation Results in, "Unable to retrieve service properties"

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Article ID: 8017

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Updated On:

Products

STARTER PACK-7 CA Rapid App Security CA API Gateway

Issue/Introduction

When I attempt to use the API Gateway Policy Manager to validate policies, I run into the following error: 

It is possible you may run into a more generic error:

<Please see attached file for image>

Memory.PNG

Environment

API Gateway 10.x version

Cause

The likely cause of the issue is Java memory allocation.

Before proceeding with the steps to increase the java memory allocation, please verify you see the following errors in the Policy Manager log called ssm0.log.

The ssm0.log is notmally located in following directory:

<root_drive>:\Users\<your_OS_user_name\.l7tech

Check the log for the following line: 

Caused by: java.lang.OutOfMemoryError: Java heap space

Resolution

If you see Java heap space messages in the ssm0.log, the resolution is to increase the amount of memory allocated to the Policy Manager. 

The policy manager .ini file defines how much memory can be allocated to the application. It is normally located in the installation path of the Policy Manager but it could be anywhere you specified during the installation.

For example :

C:\Program Files (x86)\CA Technologies - A Broadcom Company\Layer7 API Gateway Policy Manager<version>\CA API Gateway Policy Manager.ini

Resolution Steps:

  • Make a backup copy of the ini file and save it into a backup directory of your choice
  • Edit the original file with notepad or some other text editor.
  • Change "-Xmx256M" to "-Xmx512M".
    Restart the Policy Manager 
  • Test.

By default, Automatic policy validation is enabled. If it is causing problems you can disable the automatic validation via the following steps in Policy Manager

File -> Preferences -> Policy Validation Feedback

Attachments

1558700130605000008017_sktwi1f5rjvs16oxh.png get_app