After power loss Vertica won’t start.

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Article ID: 7993

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Updated On:

Products

CA Infrastructure Management CA Infrastructure Management CA Performance Management - Usage and Administration CA Performance Management - Data Polling

Issue/Introduction

Our datacenter lost power and after power was restored, we cannot successfully start Vertica.

Cause

Many systems (even Linux) are under the control of internal policies.

After a reboot, it is not uncommon for the firewall to enable and start on a Linux server.

This will cause the Vertica inter-node communication to fail and Vertica cannot start.

Check the following log:

catalog/drdata/v_drdata_node000*_catalog/startup.log (your node number will vary).

Look for this message:

{

  "node" : "v_drdata_node0002",

  "stage" : "Waiting for Cluster Invite",

  "text" : "Invited",

  "timestamp" : "2017-09-07 12:23:46.191"

 

}

Environment

CAPM 2.8, 3.x

Resolution

Verify that the firewall if not running and that all nodes in the Vertica cluster can talk to each other on the network.