Scheduled Unfied Reports do not fire on schedule
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Scheduled Unfied Reports do not fire on schedule

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Article ID: 7958

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Infrequently, scheduled Unified Reports are delayed or the email is not received.

Environment

UIM 8.5.1Unified Reporter - all versions

Cause

Unified Reports use an underlying open source technology called the quartz scheduler.

This has a limited number of threads that can run at the same time.

If there are too many reports scheduled within a short period of time, there is potential for some to "misfire" or get missed.

Resolution

On the probe machine that has the wasp probe with Unified Reports, edit this file in a text editor:

/opt/nimsoft/probes/service/wasp/webapps/reportscheduler/WEB-INF/classes/quartz.properties

Change the value of "org.quartz.threadPool.threadCount=6" to "8" or "10" or higher.

Restart the "wasp" probe on that machine.

Be mindful of CPU utilization on that machine.

 

Additional Information

The other variable in the same file: "org.quartz.jobStore.misfireThreshold=300000" is how long the Quartz scheduler will wait for any report to finish before timing it out and moving to the next one in the queue (that is not already being processed).

The value is in milliseconds. So, it is set to 5 minutes out of the box.

For very long running reports, it may be necessary to increase this with caution.

Increasing this value means the variable: "org.quartz.threadPool.threadCount" will also need to be increased as there is a danger of not processing reports fast enough.

For troubleshooting please review this log file:

/opt/nimsoft/probes/service/wasp/webapps/jasperserver-pro/WEB-INF/logs/jasperserver.log

Look for errors or info from "quartz".