iDash 12.0.03 Upgrade Fails On SLA File Migration Error
search cancel

iDash 12.0.03 Upgrade Fails On SLA File Migration Error

book

Article ID: 7888

calendar_today

Updated On:

Products

iDash Workload Automation

Issue/Introduction

During an iDash upgrade to 12.0.03 from an earlier 12.x release, the following error is encountered...

<Please see attached file for image>

Error1.PNG

After clicking 'OK' on the first error, a second error appears...

<Please see attached file for image>

Error2.PNG

After clicking 'OK' on the second error, the upgrade exits. The iDash server will restart. However, this error aborts the upgrade after the binaries are upgraded but before the necessary database schema updates are performed. This leaves iDash in an unusable state.

Environment

iDash 12.x Windows

Cause

The error migrating the SLA files occurs when the iDash home directory contains spaces. This is typical for most Windows environments because the default install location is under the "Program Files" directory.

Resolution

Under %IDASH_HOME%\.install4j, locate "response.varfile".

Open the file for editing.

Find and replace "Program Files" with "PROGRA~1" (8dot3 naming)

Save the file and re-run the upgrade. The changes resolve the SLA file migration error which will allow the upgrade to continue and complete successfully.

Attachments

1558700208386000007888_sktwi1f5rjvs16oyu.png get_app
1558700206434000007888_sktwi1f5rjvs16oyt.png get_app