Creation of CDB failed error when installing CA Service Desk Manager (CA SDM)
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Creation of CDB failed error when installing CA Service Desk Manager (CA SDM)

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Article ID: 7795

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When installing CA Service Desk Manager (CA SDM), receive a 'Creation of CDB failed' error.

The INSTALL_MDB.LOG file has the following error:

select (mdbmajorversion * 100) + mdbminorversion + 2 from mdb_version
Invalid object name 'mdb_version'. select (mdbmajorversion * 100) + mdbminorversion from mdb
Invalid object name 'mdb'

 

Environment

CA Service Desk Manager 17.x

All Supported Operating Systems

Cause

One of the most common causes of the "Invalid object name 'mdb'" error is that a blank MDB is created prior to running the CA SDM installer.

As part of the CA SDM install process, it checks to see whether a MDB exists, and if it does, it queries some of the MDB tables before proceeding.

If those tables are not present, then the install will fail.

 

Resolution

Delete any existing MDB databases that were manually created and allow the CA SDM installer to setup the MDB database.

During the CA SDM installation process, need to ensure that the installer is either pointed at a MDB instance that does not exist yet, and will be created by the installer, or at an existing MDB database (for migration/upgrade purposes).