CA TDM Portal Publish from portal 302 error for HEX values

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Article ID: 77500

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

Data pools / data flows were validated and working from Datamaker and TDM Portal before upgrading. After the last upgrade to Datamaker (GA) 4.4.0.46 and TDM Portal 4.4.0.10; TDM Portal is having issues publishing to the target DB2 database with error 302. After validating the scenarios by publishing from Datamaker to a file and then validating the values from the TDM Portal log, the only values that look different and the size do not correspond are the HEX values. For example, the calculated value for one of the columns is X'10' and the value on the insert statement is [[email protected] The rest of values are inside the boundaries of the columns definition.

Cause

The patch for 4.3 was created in Late December for the fix to this issue and did not make it into the 4.4 GA.

Environment

Datamaker 4.4.0.46 and TDM Portal 4.4.0.10

Resolution

Patch was applied.  However, now we are having a JDBC issue.  Per the documentation, https://docops.ca.com/ca-test-data-manager/4-4/en/installing/supported-data-sources/notes-on-implementation-with-specific-data-sources, the correct version/JAR files that need to be used by the new Portal version. The patch fixed the issue.  Please ask CA Support for version TDMWeb-4.4.22.0 or later and verify that it made it into that version.

Additional Information

Video URL on how to open a Support Case - https://communities.ca.com/videos/5898-demo-how-to-open-a-support-case
You can download the latest version of TDM by following the directions in this document: https://support.ca.com/us/knowledge-base-articles.TEC1903942.html.   
To contact support, go to https://www.ca.com/us/services-support/ca-support/contact-support.html