Event service error object reference not set to instance of an object at CA.Applications.WorkFlowProviders.OEM.Process.OEMExecutionStatus.GetExecutionStatus

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Article ID: 7742

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Updated On:

Products

CA IT Asset Manager CA Software Asset Manager (CA SAM) ASSET PORTFOLIO MGMT- SERVER CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

We have CA Asset Portfolio Management 14.1, C4 integrated with CA Software Asset Manager  4.2.2 

Every hour we see one of these messages in our event service log: 
System.NullReferenceException: Object reference not set to an instance of an object. 
at CA.Applications.WorkFlowProviders.OEM.Process.OEMExecutionStatus.GetExecutionStatus(DataObject obj) 
at CA.Applications.WorkFlowProviders.OEM.OEMWorkflowProvider.GetExecutionStatus(Object identifier, DataObject obj) 
at CA.Applications.EventService.EventService.OEMStatusUpdater(Object stateInfo)

Cause

Periodically, the event service will poll the SAM server for the 'execution status' of previously fired events.  If the SAM server is too busy to provide the status at that time, then this message will appear in the event service log. 

Environment

CA Asset Portfolio Management 14.1, any patch level, integrated with CA Software Asset Manager 4.1.x releases and above.

Resolution

This message can safely be ignored.  APM will continue to poll for execution status until the status is received. 

Make certain that your error is EXACTLY this message:  System.NullReferenceException: Object reference not set to an instance of an object.  CA.Applications.WorkFlowProviders.OEM.Process.OEMExecutionStatus.GetExecutionStatus(DataObject obj) at CA.Applications.WorkFlowProviders.OEM.OEMWorkflowProvider.GetExecutionStatus(Object identifier, DataObject obj) at CA.Applications.EventService.EventService.OEMStatusUpdater(Object stateInfo) 

Additional Information

You may also wish to lower the logging level for the event service log so this message is not visible.  

To lower the logging level to FATAL, edit the \CA\ITAM\Event Service\logging.config file and change all occurrences of INFO, DEBUG, or ERROR to FATAL.  Then restart the event service for the log change to take effect.