Jobs stuck in Ready state in CA Workload Automation DE

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Article ID: 76832

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Updated On:

Products

CA Workload Automation Agents DSERIES- SERVER CA Workload Automation DE - System Agent (dSeries) CA Workload Automation AE - System Agent (AutoSys)

Issue/Introduction

The CA Workload Automation DE may show jobs in READY state for indefinite period.  This can be due to several factors.

Cause

The CA Workload Automation DE submits jobs to the CA WA Agents and then waits for an update.  If the CA WA Agent is not able to communicate back, then jobs will continue to stay in READY/STARTING state.  The following issues may cause the jobs to stay to not run or complete.

 

1.  Check if the CA WA Agent are able to communicate back to the manager.  Check the transmitter.log for any communication errors like these:

04/09/2018 09:04:44.667 ...... TCP/IP Controller Plugin.Transmitter pool thread <Slow:1>.CybTargetHandlerChannel.constructConversation[:1194] - Error connecting to CA_MANAGER:
   cybermation.library.communications.CybConversationConnectException: Connection failed to: <MANAGER-ID><7507>. Connection refused
   at cybermation.library.communications.CybConversation.<init>(CybConversation.java:239)  at cybermation.library.communications.CybConversation.<init>(CybConversation.java:153)
   at cybermation.commplugins.tcpip.handler.CybTargetHandlerChannel.constructConversation(CybTargetHandlerChannel.java:1150)
..... snip .....
Caused by: java.net.ConnectException: Connection refused
  at java.net.PlainSocketImpl.socketConnect(Unknown Source)

 

2.  Check if the jobs are on READY/STARTING state on Linux and UNIX Agent.  This may be due to maximum number of file in a directory limit.

 

3. Check if the Agent received the message in Agent's receiver log located in <Agent_Installdir>/log/receiver.log.

 

Environment

CA Workload Automation DE 
CA Workload Automation System Agent 11.x

OS Linux/ UNIX

Resolution

If the issue is due to network connections, such as connection refused then check the following:

1.  Network connection, ping the manager host from agent host

2.  Check DNS resolution.  The Agent host may not be able to resolve the hostname (not Manager ID) of the scheduler server

3.  Check the Manager port from agent host.  You can get the port from manager side or from the agentparm.txt of the CA Agent.  Default is 7507.

4.  To get the ports, look for this in agentparm.txt:

communication.manageraddress_1=manager_host.example.com   
communication.managerid_1=MANAGER-ID           <- Your ID will be different
communication.managerport_1=7507


If there are no errors or any communication back to the manager in transmitter.log, then check to see if maximum number of file limit has been reached.  Before running the job, the CA Agent tries to create a spool directory to capture the spool output.  If it is unable to do so, then jobs will not run.  Check this link for more details.

 

If no message is received by the Agent in <Agent_Installdir>/log/receiver.log, then check the agent configuration with the DE manager in Topology view. 

- Make sure that the agent address (IP address/hostname) and port are defined correctly.

- Make sure that there is no firewall in place blocking communication between DE manager and Agent.