Vertica Backup Failure after upgrade to CAPM 3.2

book

Article ID: 76609

calendar_today

Updated On:

Products

CA Infrastructure Management CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

The Vertica backup is failing after upgrade to CAPM3.2 with the following error: Error: Manifest not found ... is the backup location initialized? Hint: Execute '--task init' first.

Cause

From the CAPM 3.0 and CAPM 3.1 doc 
Important: This backup behavior is new in CA Performance Management 3.0. To verify your backup procedures, create a new configuration file and a new backup directory. 

Environment

Upgrade from CAPM 2.6,2.7 and 2.8 to version 3.0 and higher. 

Resolution

Need to create a new directory for the backup and rerun the vby.py setup procedure per the documentation. 

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/performance-management/3-6/administrating/data-repository-administration/back-up-the-data-repository.html

Additional Information

https://my.vertica.com/docs/7.2.x/HTML/index.htm#Authoring/AdministratorsGuide/BackupRestore/VBRUtilityReference.htm